summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/configuration.nix b/configuration.nix
new file mode 100644
index 0000000..dedcd96
--- /dev/null
+++ b/configuration.nix
@@ -0,0 +1,45 @@
+{
+ config,
+ pkgs,
+ ...
+}: {
+ imports = [./hardware-configuration.nix];
+ nix.settings.experimental-features = ["nix-command" "flakes"];
+
+ boot.loader.grub.device = "/dev/sda";
+ time.timeZone = "Europe/Berlin";
+ i18n.defaultLocale = "en_US.UTF-8";
+
+ networking = {
+ hostName = "hostname";
+ networkmanager.enable = true;
+ };
+
+ users.users.tom = {
+ isNormalUser = true;
+ extraGroups = ["wheel" "networkmanager" "video"];
+ shell = pkgs.zsh;
+ };
+
+ programs.zsh = {
+ enable = true;
+ promptInit = ''
+ autoload -Uz vcs_info
+ precmd() { vcs_info }
+ zstyle ':vcs_info:git:*' formats '|%F{3}%b%f'
+ setopt PROMPT_SUBST
+ PROMPT='<%F{2}%n%f@%F{6}%m%f|%F{5}%~%f''${vcs_info_msg_0_}%f> '
+ '';
+ };
+ fonts.packages = [pkgs.hermit];
+ services = {
+ openssh.enable = true;
+ xserver = {
+ enable = true;
+ autorun = false;
+ displayManager.startx.enable = true;
+ };
+ };
+ system.stateVersion = "23.11";
+ zramSwap.enable = true;
+}