summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authortom barrett <tom@tombarrett.xyz>2024-05-11 21:31:48 +0200
committerTom Barrett <tom@tombarrett.xyz>2024-05-12 12:00:27 +0200
commita642918e5d9df38ee172d37aefe42f40bad80309 (patch)
tree6e5c552c5b62fc77aa684957af5db6da751c8fc5 /configuration.nix
good starting point
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/configuration.nix b/configuration.nix
new file mode 100644
index 0000000..dedcd96
--- /dev/null
+++ b/configuration.nix
@@ -0,0 +1,45 @@
+{
+ config,
+ pkgs,
+ ...
+}: {
+ imports = [./hardware-configuration.nix];
+ nix.settings.experimental-features = ["nix-command" "flakes"];
+
+ boot.loader.grub.device = "/dev/sda";
+ time.timeZone = "Europe/Berlin";
+ i18n.defaultLocale = "en_US.UTF-8";
+
+ networking = {
+ hostName = "hostname";
+ networkmanager.enable = true;
+ };
+
+ users.users.tom = {
+ isNormalUser = true;
+ extraGroups = ["wheel" "networkmanager" "video"];
+ shell = pkgs.zsh;
+ };
+
+ programs.zsh = {
+ enable = true;
+ promptInit = ''
+ autoload -Uz vcs_info
+ precmd() { vcs_info }
+ zstyle ':vcs_info:git:*' formats '|%F{3}%b%f'
+ setopt PROMPT_SUBST
+ PROMPT='<%F{2}%n%f@%F{6}%m%f|%F{5}%~%f''${vcs_info_msg_0_}%f> '
+ '';
+ };
+ fonts.packages = [pkgs.hermit];
+ services = {
+ openssh.enable = true;
+ xserver = {
+ enable = true;
+ autorun = false;
+ displayManager.startx.enable = true;
+ };
+ };
+ system.stateVersion = "23.11";
+ zramSwap.enable = true;
+}