summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..6052738
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+ outputs = {
+ self,
+ nixpkgs,
+ }: let
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ in {
+ packages.x86_64-linux.default = pkgs.stdenv.mkDerivation {
+ name = "raytracing";
+ src = ./.;
+ nativeBuildInputs = [
+ pkgs.zig_0_10.hook
+ ];
+ };
+ };
+}