summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorTom Barrett <tom@tombarrett.xyz>2024-01-21 11:14:44 +0100
committerTom Barrett <tom@tombarrett.xyz>2024-01-21 11:14:44 +0100
commit81fc6d3abd8768efe2f47098d0e7bb7782820d0a (patch)
tree3652adce9acdd55ecd74d6dd96f2125a986b4371 /flake.nix
parent39b57fa0729d16873193947b12e59a7da52695fa (diff)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..6052738
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+ outputs = {
+ self,
+ nixpkgs,
+ }: let
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ in {
+ packages.x86_64-linux.default = pkgs.stdenv.mkDerivation {
+ name = "raytracing";
+ src = ./.;
+ nativeBuildInputs = [
+ pkgs.zig_0_10.hook
+ ];
+ };
+ };
+}