summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorTom Barrett <tom@tombarrett.xyz>2023-11-04 12:03:11 +0100
committerTom Barrett <tom@tombarrett.xyz>2023-11-04 12:03:11 +0100
commit8b69ba41d10dc301af77283795ab20801160bd16 (patch)
tree1c047a1aa07119246a29533af341f7f166c06e8a /flake.nix
parentfeb122116fdb3619502c2e8d88f6dd570bc4b4ca (diff)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..e79094c
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+{
+ outputs = {
+ self,
+ nixpkgs,
+ }:
+ with nixpkgs.legacyPackages.x86_64-linux; {
+ packages.x86_64-linux.default = stdenv.mkDerivation {
+ name = "pinentry-dmenu";
+ src = ./.;
+ buildInputs = [
+ xorg.libX11.dev
+ xorg.libXinerama
+ xorg.libXft
+ gpgme
+ libconfig
+ ];
+ };
+ formatter.x86_64-linux = alejandra;
+ };
+}