diff options
author | Tom Barrett <tom@tombarrett.xyz> | 2024-02-11 13:41:47 +0100 |
---|---|---|
committer | Tom Barrett <tom@tombarrett.xyz> | 2024-02-11 13:41:47 +0100 |
commit | 69e9543d31c81419ed9a1c5c51c220480289aaa0 (patch) | |
tree | ca1a9f3350cdb3b2c92e7aa3a7e9db7d2b7feec0 /flake.nix | |
parent | edcc90d45ed5a762490f63d52d8049a8df4db9c1 (diff) |
update
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 20 |
1 files changed, 14 insertions, 6 deletions
@@ -16,12 +16,14 @@ module = { config = { extraPackages = [ - pkgs.black pkgs.alejandra - pkgs.shfmt + pkgs.black pkgs.cargo - pkgs.rustfmt + pkgs.cmake-format pkgs.go + pkgs.rustfmt + pkgs.shfmt + pkgs.yamlfmt ]; options = {mouse = "";}; colorschemes.kanagawa = { @@ -29,6 +31,7 @@ transparent = true; }; plugins = { + ledger.enable = true; lsp = { enable = true; servers = { @@ -38,20 +41,25 @@ gopls.enable = true; }; }; - rust-tools.enable = true; + rustaceanvim.enable = true; conform-nvim = { enable = true; formatAfterSave.lspFallback = false; formattersByFt = { - python = ["black"]; + cmake = ["cmake_format"]; + go = ["gofmt"]; nix = ["alejandra"]; + python = ["black"]; rust = ["rustfmt"]; - go = ["gofmt"]; + yaml = ["yamlfmt"]; _ = ["shfmt"]; }; formatters.shfmt = { prepend_args = ["-i" "4" "-s"]; }; + formatters.rustfmt = { + prepend_args = ["--edition" "2021"]; + }; }; luasnip.enable = true; nvim-cmp = { |