summaryrefslogtreecommitdiff
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
authortom barrett <tom@tombarrett.xyz>2024-05-11 21:31:48 +0200
committerTom Barrett <tom@tombarrett.xyz>2024-05-12 12:00:27 +0200
commita642918e5d9df38ee172d37aefe42f40bad80309 (patch)
tree6e5c552c5b62fc77aa684957af5db6da751c8fc5 /hardware-configuration.nix
good starting point
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
new file mode 100644
index 0000000..a09ff30
--- /dev/null
+++ b/hardware-configuration.nix
@@ -0,0 +1,44 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{
+ config,
+ lib,
+ pkgs,
+ modulesPath,
+ ...
+}: {
+ imports = [
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = ["ehci_pci" "ahci" "sd_mod" "sr_mod" "sdhci_pci"];
+ boot.initrd.kernelModules = [];
+ boot.kernelModules = ["kvm-intel"];
+ boot.extraModulePackages = [];
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/4a58083f-189f-41ff-a437-b4b78b04c686";
+ fsType = "ext4";
+ };
+
+ boot.initrd.luks.devices."root".device = "/dev/disk/by-uuid/f49dd6de-e376-47c8-8ed0-f5107317e090";
+
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/a26d8cfa-5b0e-43a2-9873-329c0488f748";
+ fsType = "ext4";
+ };
+
+ swapDevices = [];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp0s25.useDHCP = lib.mkDefault true;
+ # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}