summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authortom barrett <tom@tombarrett.xyz>2024-05-11 21:31:48 +0200
committerTom Barrett <tom@tombarrett.xyz>2024-05-12 12:00:27 +0200
commita642918e5d9df38ee172d37aefe42f40bad80309 (patch)
tree6e5c552c5b62fc77aa684957af5db6da751c8fc5 /flake.nix
good starting point
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..361a52c
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,32 @@
+{
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ nixvim.url = "git+https://git.tombarrett.xyz/nixvim";
+ home-manager = {
+ url = "github:nix-community/home-manager";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+ };
+ outputs = {
+ home-manager,
+ nixpkgs,
+ nixvim,
+ self,
+ }: {
+ nixosConfigurations."hostname" = nixpkgs.lib.nixosSystem {
+ system = "x86_64-linux";
+ modules = [
+ ./configuration.nix
+ home-manager.nixosModules.home-manager
+ {
+ home-manager = {
+ extraSpecialArgs = {inherit nixvim;};
+ useGlobalPkgs = true;
+ users.tom = import ./home.nix;
+ useUserPackages = true;
+ };
+ }
+ ];
+ };
+ };
+}