summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authortom barrett <tom@tombarrett.xyz>2024-09-21 18:41:58 +0200
committertom barrett <tom@tombarrett.xyz>2024-09-21 18:42:42 +0200
commitb7aa15adc4c1e9b76fd9cf5306ad618a2110c764 (patch)
treea45bce9ab53ae5489e242e3d1181d7d56553dac1 /configuration.nix
parent4f7a32e108e46bed8d2468d176259c255cf0e94b (diff)
update everything, add some new packagesHEADmaster
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix17
1 files changed, 6 insertions, 11 deletions
diff --git a/configuration.nix b/configuration.nix
index e5bd3b5..0081e23 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,29 +1,24 @@
-{
- config,
- pkgs,
- ...
-}: {
+{pkgs, ...}: {
imports = [./hardware-configuration.nix];
nix.settings = {
experimental-features = ["nix-command" "flakes"];
auto-optimise-store = true;
};
-
- boot.loader.grub.device = "/dev/sda";
+ boot.loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
time.timeZone = "Europe/Berlin";
i18n.defaultLocale = "en_US.UTF-8";
-
networking = {
hostName = "hostname";
networkmanager.enable = true;
};
-
users.users.tom = {
isNormalUser = true;
extraGroups = ["wheel" "networkmanager" "video"];
shell = pkgs.zsh;
};
-
programs = {
slock.enable = true;
zsh = {
@@ -47,6 +42,6 @@
displayManager.startx.enable = true;
};
};
- system.stateVersion = "23.11";
+ system.stateVersion = "24.05";
zramSwap.enable = true;
}