summaryrefslogtreecommitdiff
path: root/inc/glm/CMakeLists.txt
diff options
context:
space:
mode:
authormajortom6 <tombarrett@siu.edu>2017-02-19 09:17:35 -0600
committerTom Barrett <tombarrett@siu.edu>2017-03-07 13:23:41 -0600
commit5c46e0f0a924989201c6784b0f956bc442f14a7e (patch)
tree33b5889b872023bd7d414f7baec45706330813b3 /inc/glm/CMakeLists.txt
parent2cc21176467d4501adb7bfb9ee03eb9a2a7d14f2 (diff)
-removed glm library, its in the debian repos
-made opengl and sdl folders in includes, moved various *hpps to them
Diffstat (limited to 'inc/glm/CMakeLists.txt')
-rw-r--r--inc/glm/CMakeLists.txt43
1 files changed, 0 insertions, 43 deletions
diff --git a/inc/glm/CMakeLists.txt b/inc/glm/CMakeLists.txt
deleted file mode 100644
index fe28b5d..0000000
--- a/inc/glm/CMakeLists.txt
+++ /dev/null
@@ -1,43 +0,0 @@
-set(NAME glm_dummy)
-
-file(GLOB ROOT_SOURCE *.cpp)
-file(GLOB ROOT_INLINE *.inl)
-file(GLOB ROOT_HEADER *.hpp)
-file(GLOB ROOT_TEXT ../*.txt)
-file(GLOB ROOT_NAT ../util/glm.natvis)
-
-file(GLOB_RECURSE CORE_SOURCE ./detail/*.cpp)
-file(GLOB_RECURSE CORE_INLINE ./detail/*.inl)
-file(GLOB_RECURSE CORE_HEADER ./detail/*.hpp)
-
-file(GLOB_RECURSE GTC_SOURCE ./gtc/*.cpp)
-file(GLOB_RECURSE GTC_INLINE ./gtc/*.inl)
-file(GLOB_RECURSE GTC_HEADER ./gtc/*.hpp)
-
-file(GLOB_RECURSE GTX_SOURCE ./gtx/*.cpp)
-file(GLOB_RECURSE GTX_INLINE ./gtx/*.inl)
-file(GLOB_RECURSE GTX_HEADER ./gtx/*.hpp)
-
-source_group("Text Files" FILES ${ROOT_TEXT})
-source_group("Core Files" FILES ${CORE_SOURCE})
-source_group("Core Files" FILES ${CORE_INLINE})
-source_group("Core Files" FILES ${CORE_HEADER})
-source_group("GTC Files" FILES ${GTC_SOURCE})
-source_group("GTC Files" FILES ${GTC_INLINE})
-source_group("GTC Files" FILES ${GTC_HEADER})
-source_group("GTX Files" FILES ${GTX_SOURCE})
-source_group("GTX Files" FILES ${GTX_INLINE})
-source_group("GTX Files" FILES ${GTX_HEADER})
-
-include_directories(${CMAKE_CURRENT_SOURCE_DIR}/..)
-
-if(GLM_TEST_ENABLE)
- add_executable(${NAME} ${ROOT_TEXT} ${ROOT_NAT}
- ${ROOT_SOURCE} ${ROOT_INLINE} ${ROOT_HEADER}
- ${CORE_SOURCE} ${CORE_INLINE} ${CORE_HEADER}
- ${GTC_SOURCE} ${GTC_INLINE} ${GTC_HEADER}
- ${GTX_SOURCE} ${GTX_INLINE} ${GTX_HEADER})
-endif(GLM_TEST_ENABLE)
-
-#add_library(glm STATIC glm.cpp)
-#add_library(glm_shared SHARED glm.cpp)