summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..9a423d2
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,14 @@
+{
+ outputs = {
+ self,
+ nixpkgs,
+ }:
+ with nixpkgs.legacyPackages.x86_64-linux; {
+ packages.x86_64-linux.default = stdenv.mkDerivation {
+ name = "dwmstatus";
+ src = ./.;
+ buildInputs = [xorg.libX11.dev];
+ };
+ formatter.x86_64-linux = alejandra;
+ };
+}